Commit feea7bbb authored by Lubomir Rintel's avatar Lubomir Rintel Committed by Guillaume Roguez

packaging: use libnm instead of libnm-glib

libnm-glib has been deprecated for three years and is eventually
going to disappear.

[GR: update Debian/Ubuntu deps as well and all docker files]

Change-Id: I60a9b1a37098715ac55d5fee6718883d2a55fe3c
Reviewed-by: Guillaume Roguez's avatarGuillaume Roguez <guillaume.roguez@savoirfairelinux.com>
Signed-off-by: Guillaume Roguez's avatarGuillaume Roguez <guillaume.roguez@savoirfairelinux.com>
parent be0bb8e1
......@@ -56,7 +56,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -56,7 +56,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -58,7 +58,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -58,7 +58,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -51,7 +51,8 @@ RUN dnf upgrade -y && \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel
libvdpau-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -49,7 +49,8 @@ RUN dnf upgrade -y && \
cryptopp-devel \
libva-devel \
libvdpau-devel \
msgpack-devel
msgpack-devel \
NetworkManager-libnm-devel
# Packaging tools
RUN dnf install -y yum-utils rpmdevtools
......
......@@ -52,7 +52,8 @@ RUN dnf upgrade -y && \
cryptopp-devel \
libva-devel \
libvdpau-devel \
msgpack-devel
msgpack-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -52,7 +52,8 @@ RUN dnf upgrade -y && \
cryptopp-devel \
libva-devel \
libvdpau-devel \
msgpack-devel
msgpack-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -52,7 +52,8 @@ RUN dnf upgrade -y && \
cryptopp-devel \
libva-devel \
libvdpau-devel \
msgpack-devel
msgpack-devel \
NetworkManager-libnm-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-3.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-3.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -57,7 +57,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -67,7 +67,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -67,7 +67,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -69,7 +69,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -69,7 +69,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -69,7 +69,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -69,7 +69,7 @@ RUN apt-get update && \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev \
libnm-glib-dev \
libnm-dev \
libwebkit2gtk-4.0-dev \
libcrypto++-dev \
libva-dev \
......
......@@ -109,7 +109,7 @@ FEDORA_DEPENDENCIES = [
'yaml-cpp-devel', 'qt5-qtbase-devel', 'swig', 'qrencode-devel', 'jsoncpp-devel',
'gtk3-devel', 'clutter-devel', 'clutter-gtk-devel', 'evolution-data-server-devel',
'libnotify-devel', 'libappindicator-gtk3-devel', 'patch', 'libva-devel',
'webkitgtk4-devel', 'NetworkManager-glib-devel', 'libvdpau-devel', 'msgpack-devel'
'webkitgtk4-devel', 'NetworkManager-libnm-devel', 'libvdpau-devel', 'msgpack-devel'
]
UBUNTU_DEPENDENCIES = [
......@@ -123,7 +123,7 @@ UBUNTU_DEPENDENCIES = [
'libsndfile1-dev', 'libspeex-dev', 'libspeexdsp-dev', 'libswscale-dev', 'libtool',
'libudev-dev', 'libupnp-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev', 'libnm-glib-dev',
'libva-dev', 'libnm-dev',
'libwebkit2gtk-4.0-dev', 'libvdpau-dev', 'libmsgpack-dev'
]
......@@ -138,7 +138,7 @@ DEBIAN_DEPENDENCIES = [
'libsndfile1-dev', 'libspeex-dev', 'libspeexdsp-dev', 'libswscale-dev', 'libtool',
'libudev-dev', 'libupnp-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev', 'libwebkit2gtk-4.0-dev', 'libnm-glib-dev', 'libvdpau-dev', 'libmsgpack-dev'
'libva-dev', 'libwebkit2gtk-4.0-dev', 'libnm-dev', 'libvdpau-dev', 'libmsgpack-dev'
]
ARCH_LINUX_DEPENDENCIES = [
......@@ -147,7 +147,7 @@ ARCH_LINUX_DEPENDENCIES = [
'expat', 'gsm', 'gtk3', 'jack', 'libnotify', 'opus', 'pcre', 'libpulse', 'libsamplerate',
'libsndfile', 'speex', 'speexdsp', 'libtool', 'libupnp', 'yaml-cpp', 'qt5-base',
'swig', 'yasm', 'qrencode', 'evolution-data-server', 'make', 'patch', 'pkg-config',
'automake', 'libva', 'webkit2gtk', 'libnm-glib', 'libvdpau'
'automake', 'libva', 'webkit2gtk', 'libnm', 'libvdpau'
]
OSX_DEPENDENCIES = [
......
......@@ -21,7 +21,7 @@ Build-Depends: debhelper (>= 9),
gettext,
libqrencode-dev,
libappindicator3-dev,
libnm-glib-dev,
libnm-dev,
libwebkit2gtk-4.0-dev | libwebkit2gtk-3.0-dev,
# ring-daemon
libdbus-1-dev,
......
......@@ -62,7 +62,7 @@ BuildRequires: libnotify-devel
BuildRequires: qt5-qttools-devel
BuildRequires: qrencode-devel
BuildRequires: libappindicator-gtk3-devel
BuildRequires: NetworkManager-glib-devel
BuildRequires: NetworkManager-libnm-devel
BuildRequires: libva-devel
BuildRequires: webkitgtk4-devel
BuildRequires: cryptopp-devel
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment