Commit 221fee73 authored by Eden Abitbol's avatar Eden Abitbol

upnp: remove system upnp library dependency

The libupnp available for system download (v1.8.2) causes
intermittent crashes. The one compiled locally is a newer version
(v1.8.4) that doesn't crash.

Change-Id: I5ae02553a845488cba0c0617ec1816e2d81cd4f3
parent b26f855b
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libargon2-0-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libargon2-0-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libargon2-0-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libargon2-0-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -34,7 +34,6 @@ RUN dnf upgrade -y && \
check \
astyle \
uuid-c++-devel \
libupnp-devel \
gettext-devel \
gcc-c++ \
which \
......
......@@ -34,7 +34,6 @@ RUN dnf upgrade -y && \
check \
astyle \
uuid-c++-devel \
libupnp-devel \
gettext-devel \
gcc-c++ \
which \
......
......@@ -38,7 +38,6 @@ RUN dnf upgrade -y && \
check \
astyle \
uuid-c++-devel \
libupnp-devel \
gettext-devel \
gcc-c++ \
which \
......
......@@ -37,7 +37,6 @@ RUN dnf upgrade -y && \
check \
astyle \
uuid-c++-devel \
libupnp-devel \
gettext-devel \
gcc-c++ \
which \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libebook1.2-dev \
libcanberra-gtk3-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -18,7 +18,6 @@ RUN apt-get update && \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libupnp-dev \
libgnutls28-dev \
libargon2-0-dev \
libebook1.2-dev \
......
......@@ -75,7 +75,7 @@ ZYPPER_DEPENDENCIES = [
'curl', 'gzip', 'bzip2',
# daemon
'speexdsp-devel', 'speex-devel', 'libdbus-c++-devel', 'jsoncpp-devel', 'yaml-cpp-devel',
'libupnp-devel', 'yasm', 'libuuid-devel', 'libnettle-devel', 'libopus-devel',
'yasm', 'libuuid-devel', 'libnettle-devel', 'libopus-devel',
'libgnutls-devel', 'msgpack-devel', 'libavcodec-devel', 'libavdevice-devel', 'pcre-devel',
'alsa-devel', 'libpulse-devel', 'libudev-devel', 'libva-devel', 'libvdpau-devel',
'libopenssl-devel',
......@@ -127,7 +127,7 @@ APT_DEPENDENCIES = [
'libgtk-3-dev', 'libjack-dev', 'libnotify-dev',
'libopus-dev', 'libpcre3-dev', 'libpulse-dev', 'libssl-dev',
'libspeex-dev', 'libspeexdsp-dev', 'libswscale-dev', 'libtool',
'libudev-dev', 'libupnp1.8-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'libqt5sql5-sqlite', 'sip-tester', 'swig',
'libudev-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'libqt5sql5-sqlite', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev', 'libwebkit2gtk-4.0-dev', 'libnm-dev', 'libvdpau-dev', 'libmsgpack-dev', 'libcanberra-gtk3-dev'
]
......@@ -136,7 +136,7 @@ PACMAN_DEPENDENCIES = [
'autoconf', 'autoconf-archive', 'gettext', 'cmake', 'dbus', 'doxygen', 'gcc', 'gnome-icon-theme-symbolic',
'ffmpeg', 'boost', 'clutter-gtk', 'cppunit', 'libdbus', 'dbus-c++', 'libe-book',
'expat', 'gtk3', 'jack', 'libnotify', 'opus', 'pcre', 'libpulse',
'speex', 'speexdsp', 'libtool', 'libupnp', 'yaml-cpp', 'qt5-base',
'speex', 'speexdsp', 'libtool', 'yaml-cpp', 'qt5-base',
'swig', 'yasm', 'qrencode', 'make', 'patch', 'pkg-config',
'automake', 'libva', 'webkit2gtk', 'libnm', 'libvdpau', 'libcanberra', 'openssl'
]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment