Commit c7588a53 authored by Ming Rui Zhang's avatar Ming Rui Zhang

qml: linux qml compile requirements update

Change-Id: Ib8466fcfc7d9650d206d5bea88be98c6aecbe584
parent 0a4276b2
......@@ -154,11 +154,11 @@ LRC)](#How_to_Build_LibRingClient_(or_LRC) "wikilink") sections.
- For Debian based:
```bash
sudo apt install qtmultimedia5-dev libqt5svg5* qtwebengine5-dev qtdeclarative5-dev pandoc
sudo apt install qtmultimedia5-dev libqt5svg5* qtwebengine5-dev qtdeclarative5-dev qtquickcontrols2-5-dev qml-module-qtquick* pandoc
```
- For Fedora:
```bash
sudo dnf install qt5-qtsvg-devel qt5-qtwebengine-devel qt5-multimedia-devel qt5-qtdeclarative-devel pandoc
sudo dnf install qt5-qtsvg-devel qt5-qtwebengine-devel qt5-qtmultimedia-devel qt5-qtdeclarative-devel qt5-qtquickcontrols2-devel pandoc
```
**Build Windows Client**
......
......@@ -75,7 +75,7 @@ unix {
TARGET = jami-qt
TEMPLATE = app
QT += quick quickwidgets widgets xml multimedia multimediawidgets network webenginewidgets svg
QT += quick quickwidgets widgets xml multimedia multimediawidgets network webenginewidgets svg quickcontrols2
#check Qt version
QT_VERSION = $$[QT_VERSION]
......
......@@ -28,7 +28,6 @@
#include <QPainter>
#include <QPixmap>
#include <QtQML>
#include <QQmlApplicationEngine>
#include <QQmlContext>
#include <QQmlComponent>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment